Zephyr's SharePoint Blog

My Sharepoint world experience notes on day to day basis…..

Posts Tagged ‘Event id 5586’

Event ID 5586

Posted by fillzephyr on April 17, 2009

ERROR :

Event Type:     Error

Event Source:   Windows SharePoint Services 3

Event Category: Database

Event ID:       5586

Date:           4/16/2009

Time:           3:52:09 PM

User:           N/A

Computer:       MOSSPRD

Description:

Unknown SQL Exception 515 occured. Additional error information from SQL Server is included below.

Cannot insert the value NULL into column ‘permission path’, table ‘tempdb.dbo.#temp_______________________________________________________________________________________________________________000000000657’; column does not allow nulls. INSERT fails.

The statement has been terminated.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp


Resolution :

I was struggling with this error. I had a colleague who had setup the farm with the service account set to SA for the SQL Server.  After the farm is setup the backend SQL server’s cluster got collapsed. The Database team backup and restore the all databases including the config and all other databases. After restoring database the permission of the Service account is set to DBcreator and DBsecurity. Now when I go and try to create the webapplication from central admin and STSADM. I got this error “Unknown Error” , when i check in event viewer in application i see error of event ID 5586. I had Google about these errors but I can’t find any solution on net. When I discussed with my colleague and then gone to the database team to solve this problem. We had checked everything from the database user mail configuration settings and other stuffs it’s all set to be perfect. Still we are getting this error. At the end when we change the Service Account Permission to the SA and try to create to Webapplication, I am able to create it. Also I tried to create a root site collection and it works perfectly fine. I don’t find the perfect reason what’s creating this error but we can create a web app using Service account as SA. Also to add when I check the config and other database it was seen it was under the person’s name owner who had restore the database, but we had make the service account owner for all the databases related to SharePoint.

Any Feedback appreciated. Also anyone know the reason for these error please let me know.

Thanks

Posted in Errors, SharePoint Blogs | Tagged: , , | 1 Comment »