Zephyr's SharePoint Blog

My Sharepoint world experience notes on day to day basis…..

Archive for December, 2010

SharePoint RSS Viewer Web Part Output display

Posted by fillzephyr on December 12, 2010

I had a blog  site collection named http://abcd.net.au/sites/blog and had the blog site underneath it called http://abcd.net.au/sites/blog/test

I want to displays the blog Posts of tests  on the sub-site Demo under main Intranet Portal http://abcd.net.au

Normally if you add the rss viewer web-part it will show all the fields related to ALLPOSTS view of the test blog.

In order to show the posts with only Title and body to the rss viewer webpart you have to follow this steps.

Go to the test blog Posts lists

Open the Posts List settings

under the column called Communications there is the RSS settings Option

Select the fields you want top display in the rss viewer webpart and hit ok.

Advertisements

Posted in SharePoint Blogs | Leave a Comment »

The search service is not able to connect to the machine that hosts the administration component – SharePoint 2010 Search Service Application Error

Posted by fillzephyr on December 12, 2010

Error:

System Status Crawl status The search service is not able to connect to the machine that hosts the administration component. Verify that the administration component ‘xxxx-xxxxxxx-xxxxx-xxxxx in search application ‘Search Service Application’ is in a good state and try again.

Resolution:

Go to manage Service Application Page As shown below

Hover over the Enterprise Search Service. Go to the properties as shown below.

It opens up the page shown below. Please verify if the application pool used is SharePoint web Service Account.

If it used the application pool SharePoint web Service Account then change to other application pool from drop down as shown below.

Once you change hit OK.

It will take some time and it shows up the successful of the creation of theSearch Service Application.

Or

You can try this method by creating a new app pool. ( I had tried this after doing the above step but I don’t know what would be the outcome if you do it straight away)

Create a new app Pool

AppPool Name: SPSearch_Ent

Search Service Account: DomainName\SPSearch1

Hit Ok

Once its done successfully it will shows the above screen.

Hope this will helps.

Thanks

Posted in SharePoint Blogs | 4 Comments »